Announcement

Collapse
No announcement yet.

Clutch Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Clutch Problems

    First I'd like to introduce myself to S2KCA, My names Brad McKenzie, I'm in the Navy and I'm stationed in San Diego. I have a 2001 S2K that I've had for about 6 months and I absolutely love the thing. I'm trying to get some input on an issue with the performance of my car, or rather lack of lately. I don't want to go on replacing things I don't need cause quite frankly this is an expensive car to be buying the wrong thing for =P. I've been noticing a lack of power, and I'm trying to rule out the clutch, cause I don't notice the RPMs going higher than they normally would at certain speeds in certain gears, but I don't know what else could be the problem. When I shift from 3rd to 4th or 4th to 5th I don't feel that small jerk of the clutch engaging like I used to when I first got the car.There is literally no feeling at all, and even if I floor the damn thing in 4th it doesn't just go like it normally would, and this is over 4500-5000 rpms. It also seems like I'm getting a little more play than normal (About 2 - 2 and a half inches). Does anyone know what could be causing this? Or what I should look at?

  • #2
    Dave (Repiv) will likely check in with more info, but what you desribe does not sound like a clutch problem to me. A slipping clutch would be indicated by the engine RPM increasing without a coresponding increase in vehicle speed.

    Oh yea, Dave's regular hang out is The Xviper's Den.

    Welcome to the forum. You missed this years S2K Days. This time, the event centered in San Ramon, just East of San Francisco. We attended and had a great time!

    Again, Welcome
    Not all who wander are lost...

    We are part of that group of folks who have driven their S2000 more than 100,000 miles.

    Comment


    • #3
      I lurk everywhere.
      Please tell us as much as you can about the car. Mileage? Do you know what kinds of things have been done to it? Even routine things. What have you done to it? Can you tell us what kind of sparkplugs are in there and if you know what the gap is and how old they are. What kind of fuel do you use? Anything modded? Do you know if the car was modded once before and was put back to "stock" before you got it? Intake? Exhaust? Anything.
      What you describe is not the usual clutch problem. If it was, your rpm would climb without any proportional increase in road speed. What you're saying is the rpm doesn't seem to want to rise with authority.

      Comment


      • #4
        This may be of no help whatever. However, it may. I have a 2005 S2000 engine and gearbox in my 1991 Morgan. Not long ago (after a trip to California and some drives that included gravel roads) I noticed that it did not seem as if VTEC was kicking in. We put it on a dyno and could not find anything wrong. VTEC was kicking in but was not producing expected power. I have a K&N filter directly attached to the throttle body. I removed the filter and washed it and rinsed it thoroughly and re-oiled it. After I reinstalled it I found that performance was as I had experienced before. The filter was quite dirty - more than I would have expected - and was apparently starving the engine.
        Good luck and welcome aboard.

        Comment


        • #5
          Originally posted by repiv View Post
          I lurk everywhere.
          ..., your rpm would climb without any proportional increase in road speed.
          That's the word "proportional" I just couldn't think of it
          Not all who wander are lost...

          We are part of that group of folks who have driven their S2000 more than 100,000 miles.

          Comment

          Working...
          X